badlogic

Blog Blog: Spine 3.7.00-beta released - Audio!

Please report any issues you find here! If you have audio files that didn't load or playback, please share them here as well or send them to us via email (contact@esotericsoftware.com), linking to this thread.
User avatar
badlogic

Mario
Posts: 1013

Nate

Note that currently your WAV files must use the PCM format. We'll support other types of WAV files soon (eg, float). If you get a message your audio couldn't be loaded, check your spine.log.
User avatar
Nate

Nate
Posts: 7523

mfedorov

Cool, thanks a lot Nate!
User avatar
mfedorov
Posts: 210

denis.alenti

YEIII!!! Thank you so much guys :)
User avatar
denis.alenti
Posts: 9

Jaf

Just wow! Thanks for all the hard work guys!
Jaf
Posts: 37

PeterBacall

Just what I needed, thank you!
PeterBacall
Posts: 35

Lhescar

Awesome, a feature i was waiting for a long time! :) Thx guys.
Lhescar
Posts: 21

Wedrownik

How can I export animation to have audio in it ? :/ Tried in QuickTime, animation exports but audio doesnt :/
User avatar
Wedrownik
Posts: 88

Shiu

Keep in mind audio is still super early in Spine.
User avatar
Shiu

Shiu
Posts: 2166

bapho

Will there be support for compressed audio formats like ogg and m4a?

Ah nevermind this post. I just saw the blog
bapho
Posts: 39

Nate

We currently support WAV (currently only PCM, but we'll add the other WAV formats), OGG, and MP3.
User avatar
Nate

Nate
Posts: 7523

irmanyan

I want audio in the next official version :$
irmanyan
Posts: 1

abuki

Hi guys, do you have any estimate where this 3.7 version will be released?
abuki
Posts: 4

Nate

3.7 was released 3 months ago in beta form. To use it, you need to opt in to beta updates. See here:
http://esotericsoftware.com/spine-settings#Beta-versions
Or, you can run a specific version of Spine like this:
Spine --update 3.7.04-beta
You can see all the possible Spine versions in the changelog.
User avatar
Nate

Nate
Posts: 7523

slothwerks

@Nate - I ran into an issue where my artist created some assets using 3.7 that don't seem to be backwards compatible with the current Unity runtime (graphical issues when importing into Unity)

When would you expect that the Unity runtime might be updated to be compatible with 3.7?
slothwerks
Posts: 2

Nate

I'm afraid I don't have an ETA for when the spine-unity runtime will be updated for 3.7. We would certainly like to be making progress finishing up 3.7, but instead of had to spend a lot of effort on bug fixing to make 3.6 (and therefore 3.7) stable. It's important we don't race ahead and do too much before making the current stuff solid, though I am happy we could make audio available so quickly after 3.6.

That said, I wonder what the incompatibility was, since I would expect the 3.6 runtime to work just fine with 3.7 JSON data exports. The 3.6 runtime will just ignore the audio data. You won't be able to use binary export yet, since that is unable to ignore any part of the data.
User avatar
Nate

Nate
Posts: 7523


Return to Spine