PDev

Hello!

We just bumped in this same issue by trying to import Skeletons from Spine 4.1 into Spine-Unity 4.0-2021-09-17 and 4.0-2022-03-01.

Is that might be a new bug? Or, is Spine-Unity 4.0 not compatible with Spine 4.1?
PDev
  • Posts: 6

Harald

In general different major.minor versions (4.0 and 4.1) are incompatible. There might have been some lucky exceptions in the past, but not with 4.1.
Versioning - Spine User Guide
User avatar
Harald

Harri
  • Posts: 4164

PDev

Harald wrote:In general different major.minor versions (4.0 and 4.1) are incompatible. There might have been some lucky exceptions in the past, but not with 4.1.
Versioning - Spine User Guide
Thanks Harald.
Is there an estimate when Spine Unity runtime 4.1 will be released?
PDev
  • Posts: 6

Harald

It is available for a long time already, the github branch is named 4.1-beta, unity related packages are called 4.1-beta and are available on the download page as usual:
spine-unity Download: spine unity 4.1 beta

---

Since it has come up recently in a different context:
Please note that any error messages mentioning incompatible versions exist for a reason, when trying to work around any of these compatibility checks might seem to make everything load and work, it may throw an exception when playing any animation that uses newer serialization formats. Or even worse, it may not behave like it should in a subtile way when incorrectly interpreting the read data, failing silently.
User avatar
Harald

Harri
  • Posts: 4164


Return to Unity