SoulKarl

So occasionally, and fairly randomly, the ability to key a mesh on the hierarchy view disappears until the mesh is turned off and then on again. Obviously this undoes anything you had already done to edit the mesh on that frame, and there is an easy enough work around in swapping to auto keying momentarily, but this seems like something you should be made aware of. I attached an image to show the mesh clearly lacking the key icon completely.

Another bug inside of Unity I've had (and maybe it's already fixed, I've just worked around it since I found and reported it, so please let me know) is with the clipping masks. Inside of spine itself, the slot you set as the end of the mask is included as inside of the mask, while in unity it is considered outside. As such my work around has been to make an empty slot just to use for any given clip endpoint in the draw order. If this is fixed please let me know, and if it isn't I'll just make you guys aware again that it exists.

Cheers!
You do not have the required permissions to view the files attached to this post.
SoulKarl
  • Posts: 31

Erika

Hello, did you perhaps have a filter on when taking this screenshot? I tried to reproduce it without success. It would be very useful to find the steps to reliably reproduce it, as if we can't reproduce the problem, we can't solve it either since we see it working. Thank you for letting us know, I'll also notify Harri of the second possible bug you mentioned.
User avatar
Erika

Erikari
  • Posts: 2283

Harald

Erikari wrote:Another bug inside of Unity I've had (and maybe it's already fixed, I've just worked around it since I found and reported it, so please let me know) is with the clipping masks. Inside of spine itself, the slot you set as the end of the mask is included as inside of the mask, while in unity it is considered outside.
This should be fixed already. Please let us know in case you are experiencing the problems still, then we are of course happy to fix it.
User avatar
Harald

Harri
  • Posts: 1485

SoulKarl

thanks for the reply you two. Harald that's great to hear! I'll test it out next time I import a skeleton. Erikari, the only filter I had on was the "expand and scroll the tree as the editor selection changes" if that's what you meant. I'll test to see if I can create steps to reproduce it (and likewise if I do will test to see if it somehow never happens with that filter turned off). Cheers!
SoulKarl
  • Posts: 31


Return to Bugs