feng

我尝试使用了命令行工具,但是没有任何反应,我使用的是已激活的spine,电脑系统是win10
You do not have the required permissions to view the files attached to this post.
feng
  • Posts: 6

Misaki

也许". \ˋ "可能没有必要。如果当前目录已经是Spine文件夹,你应该可以只用Spine -h来运行它。

Perhaps ". \" may not be necessary. If the current directory is already the Spine folder, you should be able to run it with just Spine -h.
User avatar
Misaki

Misaki
  • Posts: 842

feng

I tried using spine-h but it didn't work
feng
  • Posts: 6

Misaki

你用什么命令行工具?就我试过的Windows的cmd.exe而言,它应该可以工作。

What command line tool do you use? As far as I've tried with the Windows's cmd.exe, it should work.
User avatar
Misaki

Misaki
  • Posts: 842

feng

I am also using the windows cmd
You do not have the required permissions to view the files attached to this post.
feng
  • Posts: 6

Mario

Screenshot 2022-08-15 at 08.21.17.png


What launcher version are you using? The latest 4.1.09 launcher works as intended on the CLI for example.

Please also post your spine.log file. Finally, check if antivirus software is interfering with your Spine installation.
You do not have the required permissions to view the files attached to this post.
User avatar
Mario

Mario
  • Posts: 3146

feng

My launcher version is 4.0.48,And Spine.log file is emplty

---

Mario wrote:
Screenshot 2022-08-15 at 08.21.17.png


What launcher version are you using? The latest 4.1.09 launcher works as intended on the CLI for example.

Please also post your spine.log file. Finally, check if antivirus software is interfering with your Spine installation.
1
feng
  • Posts: 6

Mario

Please update to the latest launcher on your license page.
User avatar
Mario

Mario
  • Posts: 3146

feng

Mario wrote:Please update to the latest launcher on your license page.
I
I have updated to version 4.1.09, still not working

---

Mario wrote:Please update to the latest launcher on your license page.
I
I have updated to version 4.1.09, still not working

---

Mario wrote:Please update to the latest launcher on your license page.
I
I have updated to version 4.1.09, still not working

---

Spine.log
Spine Launcher 4.1.09
Esoteric Software LLC (C) 2013-2022 | http://esotericsoftware.com
Windows 10 Pro amd64 10.0
NVIDIA Corporation, GeForce GTX 1650/PCIe/SSE2, 4.6.0 NVIDIA 456.71

---

My Spine
You do not have the required permissions to view the files attached to this post.
feng
  • Posts: 6

Misaki

Let me reconfirm, your current situation is you can run Spine via the Spine launcher, but cannot run via the command line, right?
Is there the possibility that the directory specified on the command line is wrong? For example, it is installed on a different drive instead of the C drive. If the command entered correctly but the launch failed, some error log should be displayed, but in your case nothing is displayed, so I guess it may be that the correct location was not specified in the first place.
User avatar
Misaki

Misaki
  • Posts: 842

feng

Misaki wrote:Let me reconfirm, your current situation is you can run Spine via the Spine launcher, but cannot run via the command line, right?
Is there the possibility that the directory specified on the command line is wrong? For example, it is installed on a different drive instead of the C drive. If the command entered correctly but the launch failed, some error log should be displayed, but in your case nothing is displayed, so I guess it may be that the correct location was not specified in the first place.
Yes,I can run Spine via the Spine launcher,,but cannot run comand line in windows,It work on Mac.

My spine installation path is C:\Program Files\Spine
feng
  • Posts: 6

Nate

Sorry you are still having trouble. We haven't seen this problem occur, so it's hard for us to be more helpful. For us, Spine runs correctly from the command line.

Please try the full path to Spine.exe:
"C:\Program Files\Spine\Spine.exe" --help
Nothing should appear because Spine.exe starts Spine and returns, with all output being printed to the spine.log file. Look in your spine.log afterward and you should see the help printed there.

Please delete your spine.log file and then start with this command:
"C:\Program Files\Spine\Spine.com" --help
Does the spine.log file get created again? If not, it means something stopped Spine from running very early in Spine's start up process.

When you run Spine from the command line without specifying .exe or .com, Windows will choose .com. Spine.com starts using a connection to the command line so it can print the output to the command line (and also to spine.log). It's otherwise identical to Spine.exe. If Spine.com doesn't work, there may be some problem with your Windows command line. If you have any anti-virus or anti-malware software, be sure to try turning it off.

Does the editor start if you don't specify any parameters?
"C:\Program Files\Spine\Spine.com"
Hopefully one of these things will provide us with a clue so we can fix the problem.
User avatar
Nate

Nate
  • Posts: 12016


Return to 中国Spine用户